Azure Issues
Incident Report for Verifent
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 00:26 MDT
Identified
We are aware of issues with Microsoft Azure that are causing Verifent to be inaccessible. We are monitoring the situation with Microsoft and will provide an update when service has been restored.
Posted Jul 18, 2024 - 17:17 MDT
This incident affected: Commercial Verifications and Experience Verifications.